易客CRM论坛

找回密码
注册

QQ登录

只需一步,快速开始

发新帖

5000

积分

好友

主题
发表于 2008-9-11 13:31:31 | 查看: 86946| 回复: 33
因为自己安装易客花费了不少时间,现在把自己XP下配置易客的运行环境的安装过程经验告诉给大家。
http://www.apachefriends.org/zh_cn/xampp-windows.html
到这个网页去下载XAMPP。如下图,点击XAMMPP。
install2.jpg
然后出现以下图,选择INSTALLER,点击下载。
install.jpg
下载好了以后,双击安装程序,选择ENGLISH点OK继续
1.jpg
点下一点。
2.jpg
选择目标文件夹,默认是C盘,当然自己也可以改成D盘或是其它的,注意需要类似的目录下,要把文件夹安装在根目录下。
3.jpg
如下图该打勾的打勾
4.jpg
会依次出现以下的黑乎乎的窗口,没有关系,这个会自动关闭的。
5.jpg
安装完成
6.jpg
打开软件所需要的端口。没有装IIS,SKYPE就不用理他了,如果有的话,请照图中的操作来。
7.jpg
依旧不用理这个窗口
8.jpg
完装全部完成,点击是。
10.jpg
出现以下窗口。
点击EXPLORE出现一个文件夹。然后打开htdocs文件夹,把易客的程序解压后的文件及文件夹给放进去。
当然也可以直接在地址栏内打入:C:\xampp\htdocs 或是类似的地址进入文件夹。

11.jpg

注意,还有关键的一步:
以下内容是COPY内论坛里的一个老大的,很关键,不可遗漏:
安装后需要修改apache/bin/php.ini,把zend_optimizer.enable_loader = 0改成zend_optimizer.enable_loader = 1,激活zend即可,另外把eaccelerator前面的“;”去掉,这样可以提高执行效率。

这样,XP下的易客运行环境就安装完成了。

下面打开http://localhost/install.php进行安装,如下图,点击开始。

1.jpg

出现下图,点击下一步即可。
2.jpg
然后出现下图:注意,
用户名不变,密码为空,下面要在创建数据库前打勾。用户名为root,密码仍然空在那里。
然后把网址改成我图片中的这样子(即把端口去掉),其它不动。点下一步。
3.jpg


然后下面会出现警告,没有关系,点修改即可。
4.jpg

什么都不要动(我也不知道为什么会这样,可能是BUG吧,不确定呢,反正这么做就可以装好了。),然后直接点下一步,
6.jpg
继续点下一步,如图所示倒杯茶慢慢喝,等几分钟就可以了。
7.jpg
下面就看到完装成功的提示了。点击FINISH按钮(FINISH是完成的意思,不知道易客是不是知道用户都认识这个词的,不过没有关系,点了就可以了)
8.jpg
然后就会转到http://localhost (以后本地也可以通过这个网址来登陆查看)这个网页了,用户名,密码都是admin 登陆以后就可以使用了。 这样,整个软件就安装完成了,祝大家使用开心。



以上图片放弃任何版权,易客可以任意使用

易客是个很不错的软件,希望自己能通过的一份力量帮助易客推广,让更多的人能够使用上易客。


P.S.:
进入报表/常用报表:点击常用报表时如果弹出的窗口如果只有以下内容:
Warning: domdocument::domdocument() expects at least 1 parameter, 0 given in D:\xampp\htdocs\include\phpreports\PHPReportsUtil.php on line 203

Fatal error: Call to undefined method domdocument::load() in D:\xampp\htdocs\include\phpreports\PHPReportsUtil.php on line 204

请参考SUPPORT 老大的解决方案:
http://www.crmone.cn/bbs/viewthread.php?tid=271

[ 本帖最后由 wznjsy 于 2008-9-15 13:49 编辑 ]
发表于 2008-9-11 17:00:02
谢谢您的大力支持!我们继续努力,让易客CRM变得更好。

回复 显示全部楼层 道具 举报

发表于 2008-9-18 17:15:23
常用报表出现"Warning: domdocument::domdocument() expects at least 1 parameter"问题的解决方法:
http://bugs.php.net/bug.php?id=45538
php5在windows下运行,不需要去掉php.ini中的php_domxml.dll前面的“;”,但是不要删除php_domxml.dll文件。

If you use PHP 5 in windows, you don't need to declare php_domxml.dll in your php.ini file.

回复 显示全部楼层 道具 举报

发表于 2008-9-22 09:01:54

还有有问题啊

按此步骤操作,最后一步时会提示zend optimizer没有安装,不知道是怎么回事啊!?请指教!

回复 显示全部楼层 道具 举报

发表于 2008-9-22 09:13:30

如图示

如图示如图示如图示如图示

回复 显示全部楼层 道具 举报

发表于 2008-9-22 09:39:17

插不进图?

123.jpg

回复 显示全部楼层 道具 举报

发表于 2008-9-22 09:44:37
出现这个页面的解方案如下:
安装后需要修改apache/bin/php.ini,把zend_optimizer.enable_loader = 0改成zend_optimizer.enable_loader = 1,激活zend即可

[ 本帖最后由 wznjsy 于 2008-9-22 11:20 编辑 ]

回复 显示全部楼层 道具 举报

发表于 2008-9-22 10:35:08
这个已经修改过了!?

回复 显示全部楼层 道具 举报

发表于 2008-9-22 11:19:44

回复 #8 atpatheric 的帖子

先停用APACHE(按STOP 按钮),再启动APACHE(按START按钮)。因为这个启动稍微有点慢,可能会点了之后几秒钟无反应的情况,请耐心等待即可。

回复 显示全部楼层 道具 举报

发表于 2008-9-22 15:02:10
谢谢,已搞定,可正常使用了。不过在导入原有EXCEL数据的时候,老是出错,不能完全导入。

回复 显示全部楼层 道具 举报

发表于 2008-9-23 08:55:31
不知道你那个数据量大概有多少?
易客是一个很成熟的产品,你说的那个问题应该不会出现。
个人有导入一万多条的记录。大概一次1500条比较合适。我一条记录大概四个字段。这个数据你可以参考下。

另外,你的EXCEL是否使用了公式?我导入前把公式转换成了数据了。

回复 显示全部楼层 道具 举报

发表于 2008-10-20 10:26:46
Linux操作系统安装xampp后,怎么激活zend?没找到啊,在/opt/lampp/etc/php.ini中没有激活选项?

[ 本帖最后由 sohue 于 2008-10-20 10:32 编辑 ]

回复 显示全部楼层 道具 举报

发表于 2008-10-20 10:35:23
linux下需要自己装zend的,版本要在3.30以上的.

回复 显示全部楼层 道具 举报

发表于 2008-12-28 15:15:27
Unable to connect to database Server. Invalid mySQL Connection Parameters specified     

请管理员看一下 这是什么原因导致,     谢谢

回复 显示全部楼层 道具 举报

发表于 2008-12-28 15:17:33
原帖由 辉枫 于 2008-12-28 15:15 发表
Unable to connect to database Server. Invalid mySQL Connection Parameters specified     

请管理员看一下 这是什么原因导致,     谢谢



已经解决了。   

回复 显示全部楼层 道具 举报

您需要登录后才可以回帖 登录 | 注册

手机版|小黑屋|Archiver|易客CRM ( 沪ICP备12019426号  

GMT+8, 2017-11-24 12:00 , Processed in 0.244139 second(s), 39 queries .

Powered by Discuz! X3.1

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表